//
estás leyendo...
SharePoint - Productividad

Columnas calculadas de SharePoint – Sexta Parte

Comprobar si el valor de una columna o una parte de ella coincide con un texto concreto
Para comprobar si el valor de una columna o una parte concuerda con texto concreto, use las funciones SI, ENCONTRAR, HALLAR o ESNUMERO.
Columna1
Fórmula
Descripción (resultado posible)
Trujillo
=SI([Columna1]=”Trujillo”, “Correcto”, “Incorrecto”)
Comprueba si Columna1 es Trujillo (Correcto)
Trujillo
=SI(ESNUMERO(ENCONTRAR(“t”,[Columna1])), “Correcto”, “Incorrecto”)
Comprueba si Columna1 contiene la letra t (Correcto)
BD123
=ESNUMERO(ENCONTRAR(“BD”,[Columna1]))
Comprueba si Columna1 contiene BD (Sí)
Contar las columnas que no están en blanco
Para contar las columnas que no están en blanco, use la función CONTARA.
Columna1
Columna2
Columna3
Fórmula
Descripción (resultado)
Ventas
19
=CONTARA([Columna1], [Columna2])
Cuenta el número de columnas que no están en blanco (2)
Ventas
19
=CONTARA([Columna1], [Columna2], [Columna3])
Cuenta el número de columnas que no están en blanco (2)
Quitar caracteres del texto
Para quitar caracteres del texto, use las funciones LARGO, IZQUIERDA y DERECHA.
Columna1
Fórmula
Descripción (resultado)
Vitamina A
=IZQUIERDA([Columna1],LARGO([Columna1])-2)
Devuelve 8 (10-2) caracteres, comenzando por la izquierda (Vitamina)
Vitamina B1
=DERECHA([Columna1], LARGO([Columna1])-9)
Devuelve 2 (11-9) caracteres, comenzando por la derecha (B1)
Quita los espacios del principio y el final de una columna
Para quitar los espacios de una columna, use la función ESPACIOS.
Columna1
Fórmula
Descripción (resultado)
    ¡Hola por ahí!
=ESPACIOS([Columna1])
Quita los espacios del principio y el final (¡Hola por ahí!)
Repetir un carácter de una columna
Para repetir un carácter de una columna, use la función REPETIR.
Fórmula
Descripción (resultado)
=REPETIR(“.”,3)
Repite un punto 3 veces (…)
=REPETIR(“-“,10)
Repite un guión 10 veces (———-)

Comentarios

Aún no hay comentarios.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Enter your email address to follow this blog and receive notifications of new posts by email.

Únete a otros 59 seguidores

Blog Stats

  • 27,446 hits

Archivo

A %d blogueros les gusta esto: